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1. OVERVIEW  

What Does It Take To Create Your Own Custom Processor-Based Embedded System? 

This lab teaches you how to create a system implemented in programmable logic. You build a processor-

based hardware system and run software on it.  As the lab progresses, you will see how quick and easy it is to 

build entire systems using Altera’s QSys to configure and integrate pre-verified IP blocks. 

Lab Notes: 

Many of the names that the lab asks you to choose for files, components, and other objects in this exercise 

must be spelled exactly as directed. 

This nomenclature is necessary because the pre-written software application includes variables that use the 

names of the hardware peripherals. Naming the components differently can cause the software application to 

fail. 

There are also other similar dependencies within the project that require you to enter the correct names. 

Note: This lab guide requires an Arrow Electronics BeMicro Max 10 FPGA Evaluation Board 

(www.arrow.com/bemicro). 

Figure 1-1: BeMicro Max 10 Development Kit 
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1.1 Block Diagram 

Below is a block diagram of the board. 

Figure 1-2: BeMicro Max 10 Block Diagram 
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2. GETTING STARTED 

Module Objective 

Your first objective is to ensure that you have all of the items needed and to install the tools so that you are 

ready to create and run your design. 

List of required items 

 Arrow Electronics BeMicro Max 10 FPGA Evaluation Board 

 Design Software (Quartus
®
 II Web Edition design software v14.0 Update 2., Nios

®
 II EDS 14.0) 

 Intel Pentium III or compatible Windows PC, running at 866MHz or faster, with a minimum of 512MB of system 
memory.   

 Lab Design Files 

  

2.1 Acquire the BeMicro Max 10 FPGA Evaluation Kit 

This development kit can be ordered from http://www.arrow.com/bemicro  

2.2 Software Tools Required  

This section lists the required software design tools and explains how to install the software needed to create 

and compile designs for your MAX 10 FPGA. 

List of Required Software: 

 Altera Quartus II v14.0 with Update 2 (or newer) 

 BeMicro Max 10 Evaluation Kit Files 

 USB-Blaster™ Driver 
 

If you have not yet installed the above software, please follow the instructions found in the “BeMicro Max 10 

Getting Started User Guide”. 

 

http://www.arrow.com/bemicro
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3. EXAMINE THE SYSTEM DESIGN 

Developing software for an Altera system on a programmable chip requires an understanding of the design 

flow between the QSys system integration tool and the Nios II Embedded Development Suite (EDS). Typically, 

design requirements begin with customer requirements and become inputs to system definition. System 

definition is hence the first step in the design flow process.  Examine the system architecture and development 

tools that you will be using today. 

3.1 Examine the System Tool Flow 
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The above diagram depicts the typical flow for system design. System definition is performed using QSys. The 
results are two-fold: 

 System description that the Nios II Software Build Tools, the software development tool, uses to 
create a new project for the software application. 

 HDL files for the system that are used by the Quartus II FPGA design software to compile and 
generate the hardware system. 

The output of the Hardware Flow is an FPGA image that is used to configure the FPGA. The output of the 
Software Flow is an executable from which the Nios II processor executes instructions.  
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3.2 System Architecture 

The BeMicro Max 10 kit is architected using the components shown in the sketch below:  

 

The system above can be created in QSys using a standard library of re-useable IP blocks. The System 
Interconnect Fabric is automatically generated by QSys and binds the blocks together. The system 
interconnect manages dynamic bus-width matching, interrupt priorities, arbitration and address mapping.  This 
system is a full-featured processor system capable of running operating systems such as uC-OSII or  Linux.   

The following pages will guide you through the process of building a basic embedded system.  You will build up 
a subset of the system shown above.   
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4. SET UP THE QUARTUS II PROJECT 

In this section, you create a new Quartus II project to contain the QSys system. The top level is a schematic 

file, which at this stage, is a placeholder containing some minimal reset logic, i.e. a counter that issues a reset 

to the QSys system in response to a hard reset. 

In addition you will specify I/O constraints and settings for this design by executing a Tcl script. 

4.1 Create New Quartus II Project 

 Launch the Quartus II 14.0 software from Start -> All Programs -> Altera 14.0.0.200 Web Edition 
-> Quartus II Web Edition 14.0.0.200 (64-bit) -> Quartus II 14.0 (64-bit). 

 

 Click on File -> New Project Wizard. This will launch the New Project Wizard.  An “Introduction” 
dialogue box may appear.  If so, click Next to move to the dialogue box for the Name, Directory and 
Top-Level Entity. 

 For the working directory for the project, click the Browse button indicated by the “…” symbol and 
navigate to the folder ‘bemicro_m10_embedded_lab_14_0’ located in the unzipped lab design 
files. This will be the working directory for your project.  

 

 Name the project “bemicro_m10_nios2” as shown above. 
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 For the top-level entity click on “…” and then you may need to change directories to end up in the 
…/bemicro_m10_embedded_lab_14_0/ directory.  Select “bemicro_m10_nios2_top.vhd” as the 
top-level VHDL file.  

  

 Click Next.  

4.2 Add Files to the Project 

 In the Wizard window page 2 of 5 you will add files to the new project. 

 Click the Browse button and navigate to the project directory and open the folder entitled 
“bemicro_m10_embedded_lab_14_0”. 
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 Select and click Open to add the appropriate top-level file that you chose in the previous step: 
bemicro_m10_nios2_top. 

 Click the Add button to add the file to the listing and it should now be listed in the table of the wizard as 
shown below. 

 
 

 

  Click Next. 
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4.3 Specify Family and Device Settings 

In this page you select the MAX 10 device, which is the device mounted on your BeMicro Max 10 circuit 
board.   

 First you will need to select MAX 10 FPGA (DA/DF/DC/SA/SF/SC) from the Family pulldown.  

 Our kit makes use of a DA variant of the MAX 10 device, so choose MAX 10 FPGA DA from the 
Devices pulldown. 

 You can then use the “Show in ‘Available devices’ list” option to filter the list of available devices to 
make selection easier. Select FBGA for the package type, 484 for the pin count.  This will give you a 
shorter list of devices to choose from. 

 Look at the device on your kit and select the exact part number that matches from the “Available 
devices” list as shown below.  Depending on when you purchased your BeMicro Max 10 kit, it will be 
either 10M08DAF484C8GES  or 10M08DAF484I7G 

 

Click Next. 

4.4 Select EDA Tool Settings 

 Leave <None> selected for all of the options as we will not be using any third party EDA tools. Click 
Next. 

 You will see a Summary page. Click Finish. 

 



Set Up the Quartus II Project 
 

BeMicro Max 10 Getting Started User Guide, Version 14.0 11 
 

4.5 Execute Setup Script 

The I/O pin constraints have been programmed into a Tcl script in order to set up the Quartus II project 

properly.  

 Under the Tools menu, select “Tcl Scripts…”. 

 In the Tcl Scripts dialog box choose the “pin_assignments.tcl” script. 

 Click Run.  (Make sure to click "Run" prior to clicking "Close".) 

 

CONGRATULATIONS!!  

Your Quartus II project is set up. You are ready to start building your QSys system. 



Build the QSys System 
 

BeMicro Max 10 Getting Started User Guide, Version 14.0 12 
 

5. BUILD THE QSYS SYSTEM 

Module Objective 

In this module you add the standard and custom components to the system, make connections where 

required, assign the clocks, set arbitration priorities and generate the system.  

5.1 Launch QSys 

 From the Tools menu, select “QSys”.  There may be a slight delay while the QSys application 
launches. 

5.2 Understand the Clocks and PLLs 

There is a 50 MHz oscillator on the BeMicro Max 10 circuit board and this will be the clock source input. 
Other clocks are also required for the QSys system components as well as for external components such 
as the SDRAM and the internal ADC.  PLLs will be used to provide these clocks. The following table 
reviews the clocking scheme: 

Clocking Scheme     

Component Name Input Clock 

Frequency 

Source Designation 

1. SDRAM PLL 50 MHz Oscillator on 

BeMicro Max 10 

clk_50 

2. Nios II processor and 

peripherals 

80 MHz Output ‘c0’ of PLL sdram_pll_c0 

3. SDRAM phase shifted 

clock 

80 MHz  

(-90°) 

Output ‘c1’ of PLL sdram_pll_c1 

4. Slow Peripherals 40 MHz Output ‘c2’ of PLL pll_c2 

5. ADC PLL 50 MHz Oscillator on 

BeMicro Max 10 

clk_adc 

6. internal ADC 10 MHz Output ‘c0’ of ADC 

PLL 

adc_pll_c0 

Perform the following instructions to build the system. It is helpful to have the rough sketch of your system 

handy so you can follow along. 

5.3 Build the QSys System 

1. Add an Avalon ALTPLL for the Procesor, Peripherals and SDRAM 

Reason: This peripheral instantiates a PLL which will generate the clocks for the system. 
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From the IP Catalog pane, expand “Basic Functions,” then expand “Clocks; PLLs and Resets,” then 

expand “PLL” and double click on “Avalon ALTPLL.”  

  

 “General/Modes” tab (Page 1) of PLL MegaWizard. Change the frequency of the clock input to 50 
MHz. This source is provided by the oscillator on the BeMicro Max 10 circuit board. 
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Click Next to move to the next tab of the wizard.  (You may need to scroll down to see the Next button.) 

 “Inputs/Lock” tab (Page 2): Uncheck both “Create an ‘areset’ input to asynchronously reset the 
PLL” and “Create ‘locked’ output” options.  
Accept all other defaults. 

  

 Pages 3-5: Accept all defaults. 

 



Build the QSys System 
 

BeMicro Max 10 Getting Started User Guide, Version 14.0 15 
 

 On “c0 Core/External Output” (Page 6): Click “Enter output clock frequency”. Configure c0 as 80 
MHz output. Click on the “Enter output clock frequency” button and enter 80 MHz.  This clock will be 
used as the processor system clock, clocking the Nios II processor and the SDRAM controller. 

 

 “c1 Core/External Output” (Page 7): Click “Enter output clock frequency”. Configure c1 as 80 MHz 
output. Check the “Use this clock” button.  Click on the “Enter output clock frequency” button and enter 
80 MHz.  This clock will be used to clock the external SDRAM.   In the Clock phase shift enter -90 and 
leave the units set to deg.  
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 “c2 Core/External Output” (Page 8): Click “Enter output clock frequency”. Configure c2 as 40 MHz 
output. Check the “Use this clock” button.  Click on the “Enter output clock frequency” button and enter 
40 MHz.  This clock will be used to clock various peripherals in the system. 

 

 Click Finish. This will take you to the summary tab. 

 Click Finish again to close the Avalon ALTPLL MegaWizard. 

 A component entitled “altpll_0” should appear under Module Name.  Rename the Avalon ALTPLL 
component from “altpll_0” to “sdram_pll”.  (You can right click to bring up a menu with a rename 
option.)   

 Some errors and warnings will appear in the bottom console indicating that various ports are not 
connected.  Ignore these for now. We will address these connections in the upcoming steps. 

2. Add a 2nd Avalon ALTPLL for the Internal ADC 

Reason: The internal ADC has specific requirements for its clock source, so we 

will use another PLL to generate a 10 MHz clock for the ADC. Due to the pin 

location of the external SDRAM clock output, the PLL created for the SDRAM 

clock in the previous step cannot be shared as the clock source for the internal 

ADC, so a 2nd PLL is used. 

Once again, from the IP Catalog pane, expand “Basic Functions,” then 

expand “Clocks; PLLs and Resets,” then expand “PLL” and double click on 

“Avalon ALTPLL.”  
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 “General/Modes” tab (Page 1) of PLL MegaWizard. Change the frequency of the clock input to 50 
MHz. This source is provided by the oscillator on the BeMicro Max 10. 

  

Click Next to move to the next tab of the wizard.  (You may need to scroll down to see the Next button.) 
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  “Inputs/Lock” tab (Page 2): Uncheck both “Create an ‘areset’ input to asynchronously reset the 
PLL” and “Create ‘locked’ output” options.  
Accept all other defaults. 

  

 Pages 3-5: Accept all defaults. 
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 On “c0 Core/External Output” (Page 6): Click “Enter output clock frequency”. Configure c0 as 10 
MHz output. Click on the “Enter output clock frequency” button and enter 10 MHz.  This clock will be 
used as the clock source for the internal ADC block. 

 

 Click Finish. This will take you to the summary tab. 

 Click Finish again to close the Avalon ALTPLL MegaWizard. 

 A component entitled “altpll_0” should appear under Module Name.  Rename the Avalon ALTPLL 
component from “altpll_0” to “adc_pll”.  (You can right click to bring up a menu with a rename option.)   

 Some errors and warnings will appear in the bottom console indicating that various ports are not 
connected.  Ignore these for now. We will address these connections in the upcoming steps. 

3. Name the Clocks  

Reason: We will be using the using the various clock generated by the PLL to clock the components in our 

system.  Naming them will allow us to better manage and keep track of our clocking architecture. 

 Select: View -> Clocks: 

 

 Double click into the clk_0 field and rename it from clk_0 to clk_50.  
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 The default frequency already filled in is 50.0 MHz.  This just happens to match the frequency of the 
input oscillator on the BeMicro Max 10.  Leave the frequency set at 50.0. 

 Similarly, double click into each of the pll_c0, pll_c1 and pll_c2 fields and rename them sdram_pll_80, 
sdram_pll_80shift and sdram_pll_40 respectively. 

 Rename the adc_pll_c0 to adc_pll_10 

 Your Clock Settings should now appear as follows: 

 

4. Connect the incoming clock and reset to the PLL 

Reason: QSys needs to know what clock and reset sources to use as the input to the PLL component.  
The clock and reset sources can come from an external source or from another component within the 
QSys system.  In our case, we will be connecting them to an external clock and reset.   

 Click on the "System Contents" tab to return to the view of the components in our system.  At this 
point, there are two components, a "Clock Source" component that was in the system by default when 
QSys first launched and the "Avalon ALTPLL" component that we added in the first step.  The Clock 
Source component is a QSys component which brings in a clock and reset source from outside of the 
QSys system.  We will connect its nodes to the corresponding nodes on the Avalon PLL component. 

 In the "Connections" column, hover over the connections and you will then be able to fill in connection 
dots to make connections.   
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 Connect the clk clock output port of the Clock Source to the inclk_interface of the sdram_pll 
component and the inclk_interface of the adc_pll_component.  Similarly connect the clk_reset reset 
output port of the Clock Source to the inclk_interface_reset of the Avalong ALTPLL component.  Your 
resulting connections should look as follows: 

  

The phase shifted c1 output of the sdram_pll, which we named sdram_pll_80shift will need to be sent out 
of the QSys system to an FPGA output pin. To facilitate this, we need to export this signal.   

 Double-click on the “Double-click to export” text in the export column for the c1 output named 
sdram_pll_80shift interface of the sdram_pll. 

 Name the exported signal sdram_pll_80shift 
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5. We have not yet saved our system.  Let us use this opporunity to save our work.  Click on Save As from 
the File menu and save the system as nios2_bemicro_system. 

 
 
As your work through the design, occasionally save your work using Save on the File menu. 

6. Add a Nios II Processor 

Reason: A CPU is needed to run the software applications. 

 From the IP Catalog pane, under the Library.  Expand Embedded 
Processors and double click on Nios II Gen2 Processor 
(Preview).  
 

 Ensure that the Nios II/f core is selected.  

 For the Multiplier implementation options, select “High-
performance 32-bit”.  This will implement a multiplier unit within 
the Nios II’s ALU using FPGA 9-bit multipliers, which are available 
in the MAX 10 architecture. 
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 Click on the JTAG Debug tab and change the number of Hardware Breakpoints from 0 to 2. 

 

 There are numerous other options on the various pages of the dialog box.  All the remaining defaults 
should be accepted. Click Finish.  
 

 Rename the Nios II component from "nios2_gen2_0" to “nios2_cpu”. 
 

7. Configure clock source for the Nios II processor 

 At this point there are 4 components in the system.  From the drop-down list in the Clock column, 
double-check that the PLL is set up with the clk_50 source.  Note that we made this connection with 
the connection dots in an earlier step.  Then change the setting for the nios2_cpu to be driven by the 
sdram_pll_80 source.  Notice that the connection in the "Connections" column is automatically made 
for you.  Either method can be used to make clock connections in QSys.  Your system should now look 
as follows: 
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 For the remainder of the components, we will continue to make our clock connections by this method of 
using the pulldown menu in the clock column.   

 To simplify the number of lines shown in the connections patch panel column, let us change the 
connections view filter to make it easier to see what connections we are making in the upcoming steps.  

Click on the filter icon  and change the filter to Hide Clocks and Resets, then click the  to 
close the Filters window. 

 

 Connect the pll_slave of both the sdram_pll and the adc_pll to the data_master of the nios2_cpu. 
Your system should now look as follows: 
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8. Add an on-chip RAM 

Reason: Altera FPGAs provide internal on-chip memory blocks that can be used to build up an internal 

RAM (or ROM) block of memory. This provides the processor with access to very low-latency, high-speed 

memory for code or variable storage.  

 Expand Basic Functions, then expand On Chip Memory and double click on On-Chip Memory 
(RAM or ROM). 
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 Set the “Total memory size” to 16k bytes to create a 16 KB RAM. Click Finish. 

 

 Right click on the Name field and choose Rename from the pop up menu. Name this RAM 
component “onchip_ram”. 

 Using the Clock column, change the clock Input of the onchip_ram to the sdram_pll_80 clock 
source.  

 Using the Connections column, connect the s1 Avalon Memory Mapped Slave interface of the 
onchip_ram to the nios2_cpu/instruction_master and nios2_cpu/data_master.   
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9. Add an SDRAM Controller 

Reason: The BeMicro Max 10 kit contains an external SDRAM device which can be used as additional 

RAM in addition to the internal on-chip RAM. 

 Expand Memories Interfaces and Controllers.  Expand SDRAM and double click on SDRAM 
Controller. 

 

 In the dialog box on the right-hand side, under the Presets section, select BeMicro MAX 10 – ISSI 
IS42S16400J-7TL and click Apply. 
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 Then click Finish. 

 Right click on the Name field and choose Rename from the pop up menu. Name this RAM 
component “sdram”. 

 Using the Clock column, change the clock Input of the sdram to the sdram_pll_80 clock source.  

 Using the Connections column, connect the s1 Avalon Memory Mapped Slave interface of the 
sdramto the nios2_cpu/instruction_master and nios2_cpu/data_master.   

 

 

10. Add an On-Chip Flash 

Reason: The MAX 10 FPGA contains on-chip flash which is used to store the FPGA configuration and can 

also be used to store Nios II code or other non-volatile data. 

 Expand Basic Functions.  Expand On Chip Memory and double click on Altera On-Chip Flash. 
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 Leave the options at the default settings and click Finish. 

 

 Rename the component to ufm_flash 

 In the clock column, select sdram_pll_80 as the clock for the ufm_flash. 

 

 Connect the data to both nios2_cpu/data_master and nios2_cpu/ instruction_master  
 

 Connect the csr (control and status registers) to the nios2_cpu/data_master only. 
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11. Add a BeMicro Max 10 Serial Flash Controller 

Reason: The BeMicro Max 10 kit contains an external serial flash device which can be used as additional 

flash storage in addition to the internal User Flash Memory (UFM). 

 In the Project section of the IP Catalog, expand Memories Interfaces and Controllers.  Expand 
Flash and double click on BeMicro Max 10 - Serial Flash Controller. 

 

 Leave the options at the default settings and click Finish. 

 

 Rename the component to serial_flash_controller 

 In the clock column, select sdram_pll_80 as the clock for the serial_flash_controller. 

 

 Connect the epcs_control_port to both nios2_cpu/data_master and nios2_cpu/ 
instruction_master  
 

 Connect the irq to the nios2_cpu/irq 
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12. Add a SPI port for the Accelerometer 

Reason: The BeMicro Max 10 kit contains an external 3-axis accelerometer device (ADXL362) with a SPI 

interface. 

 Expand Interface Protocols.  Expand Serial and double click on SPI (3-wire serial). 

 

 Accept the default settings and click Finish. 

 Rename the component to “spi_accelerometer”. 

 In the clock column, select sdram_pll_80 as the clock for the spi_accelerometer. 

 

 Connect the spi_control_port to only the nios2_cpu/data_master  
 

 Connect the irq to the nios2_cpu/irq 
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13. Add a Internal MAX 10 ADC core 

Reason: The MAX 10 FPGA includes an analog block with ADC core. 

 Expand Processors and Peripherals.  Expand Peripherals and double click on Altera Modular 
ADC core (Beta). 

 

 Leave the default settings on the General tab. 

 Click on the Channels tab and enable the following channels (1,2,3,4,9,11,12,16) which are used 
on the BeMicro Max 10.  Refer to the “BeMicro Max 10 Getting Started User Guide” for details on 
the analog channel usage on the kit. 

 Click on the Sequencer tab and for the Number of slot used select 8. 

 Using the pulldown menus, arrange the channels into the sequencer slots as shown below.   
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 Click Finish 

 Rename the component to “modular_adc”. 

 In the clock column, select sdram_pll_80 as the clock for the modular_adc/sequencer_csr. 

 
You will see that the two ports below will automatically also switch to the same sdram_pll_80 clock. 

 Connect the sequencer_csr to only the nios2_cpu/data_master  

 Connect the sample_store_csr to only the nios2_cpu/data_master. 
 

 Connect the irq to the nios2_cpu/irq 
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 The modular ADC core has some additional connections that need to be made.  To make these 

connections, right click on the component and go to the “Connections” and then 
“modular_adc.adc_pll_clock” and then select “adc_pll.c0” to make this connection. 

 
 Similarly, right click on the component again and go to the “Connections” and then 

“modular_adc.adc_pll_locked” and then select “adc_pll.locked_conduit” to make this 
connection. 
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14. Add a SPI port for the DAC 

Reason: The BeMicro Max 10 kit contains an external DAC device (AD5681) with a SPI interface. 

 Expand Interface Protocols.  Expand Serial and double click on SPI (3-wire serial). 

 

 Accept the default settings and click Finish. 

 Rename the component to “spi_dac”. 

 In the clock column, select sdram_pll_80 as the clock for the spi_dac. 

 

 Connect the spi_control_port to only the nios2_cpu/data_master  
 

 Connect the irq to the nios2_cpu/irq 
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15. Add Avalon-MM Clock Crossing Bridge Peripheral for the “slow” peripherals. 
Reason: We will place several “slow” peripherals in a separate clock domain from the Nios II processor.  

While QSys can automatically handle crossing clock domains even if a bridge is not used, adding the 

bridge allows more control on crossing the clock domains.  If the bridge were not explicitly added, QSys 

would insert clock domain crossing logic for each peripheral. With the bridge, a single clock crossing bridge 

is built into the system for all of the slow peripherals. 

From the IP Catalog menu, expand Basic.  Expand Bridges and Adapters. Expand Memory Mapped 

and double click on Avalon-MM Clock Crossing Bridge. 

Change the Address Units to WORDS. Change the Command FIFO depth to 8 and the Response FIFO 

depth to 32. 

 

 Click Finish. 
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 Right click on the Name field and choose Rename from the pop up menu. Name this bridge 
“slow_periph_bridge”. 

Connect the nios2_cpu’s data_master port to the s0 Avalon Memory Mapped Slave of this 

bridge. The m0 master port will be connected in the upcoming steps. 

In the clock column, select sdram_pll_80 as the clock for the s0_clk 
In the clock column, select sdram_pll_40 as the clock for the m0_clk 
 

 

16. Add PIO Peripheral for LEDs 

Reason: The BeMicro Max 10 has 8 LEDs on it. You can drive these LEDs with an output PIO peripheral.  

We will drive 7 of the LEDs with a PIO peripheral.  (The 8th LED will be controlled by a custom PWM 

peripheral added in the next step.) 

 From the IP Catalog menu, expand Peripherals, expand Microcontroller Peripherals and double 
click on PIO (Parallel I/O). 

 Set the “Width” to 8 bits. Ensure that the “Direction” is set to “Output ports only”. Click Finish. 
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 Rename the peripheral “led_pio”. 

 Change the connection on the s1 slave port of the peripheral to be connected to the m0 master port 
of the slow_periph_bridge.   

 In the clock column, select sdram_pll_40 as the clock for the clk Clock Input 

 Finally, click in the "click to export" field next to the external_connection Conduit Endpoint and 
name: led_pio_external 

17. Add PIO Peripheral for Pushbutton Switches 
Reason: The BeMicro Max 10 has four pushbutton switch labeled “SW1”, “SW2”, “SW3” and “SW4” 

connected to four of the FPGA I/O pins. You can use an input PIO peripheral to detect when any of these 

pushbuttons have been pressed and signal an interrupt to the processor. 

 From the IP Catalog menu, expand Peripherals, expand Microcontroller Peripherals and double 
click on PIO (Parallel I/O). 

 Set the “Width” to 4 bits.  Set “Direction” to “Input ports only”. 

 Check the Synchronously capture and Falling edge options in the Edge capture register section.  

 Check the Generate IRQ and Edge options in the Interrupt section: 

 Check the Hardwire PIO inputs in the test bench option and drive the inputs to 0xf 

  Click Finish  
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 Rename the peripheral “button_pio”. 

 Change the connection on the s1 slave port of the peripheral to be connected to the m0 master port 
of the slow_periph_bridge.   

 In the clock column, select sdram_pll_40 as the clock for the clk Clock Input 

 Finally, click in the "click to export" field next to the external_connection Conduit Endpoint and 
name: button_pio _external 

 

18. Add a 1 ms Interval Timer Peripheral 

Reason: Many software applications require periodic interrupts to maintain various time bases and timing 

requirements within the application.  

 From the IP Catalog menu, expand Peripherals, expand Microcontroller Peripherals and double 
click on Interval Timer. 

 Change the timer interval to 1 ms. Click Finish. 

 

 Rename the component “timer”.  

 Connect the s1 slave port of the peripheral to be connected to the m0 master port of the 
slow_periph_bridge.  To do this you will need to hover your mouse over the connections area and 
pay attention to which line is the connection to the m0 master port of the bridge.  
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 In the clock column, select sdram_pll_40 as the clock for the clk Clock Input. 

 When you move your mouse cursor away, the connections should look as shown in the figure 
below.  Double check these connections carefully: 
 

 

19. Add an I2C Peripheral for accessing the On-board Temperature Sensor 

Reason: The BeMicro Max 10 has an I2C temperature sensor device (ADT7420). You can use an I2C 

peripheral to access this temperature sensor device. 

 Under the IP Catalog, go to the Project  section and expand Interface Protocols, expand Serial 
and double click on I2C Master (opencores.org). 

 The default settings are acceptable.  Click Finish. 

 

 Rename as “i2c_temp_sense”. 

 Change the connection on the avalon_slave_0 slave port of the peripheral to be connected to the 
m0 master port of the slow_periph_bridge.   

 In the clock column, select sdram_pll_40 as the clock for the clk Clock Input 
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 Finally, click in the "click to export" field next to the external_connection Conduit Endpoint and 
name: i2c_temp_sense 

20. Add JTAG UART Peripheral 

Reason: Many software developers like to have access to a debug serial port from the target to leverage 

printf debugging, input control commands, log status information, etc. The JTAG UART peripheral connects 

to the debugger console and is useful for these purposes. 

 From the IP Catalog menu, expand Interface Protocols, expand Serial and double click on JTAG 
UART. 

 The default settings are acceptable. Click Finish. 

 Rename as “jtag_uart”. 

 Change the connection on the s1 slave port of the peripheral to be connected to the m0 master port 
of the slow_periph_bridge.   

 In the clock column, select sdram_pll_40 as the clock for the clk Clock Input 

 

 

21. Add a System ID 

Reason: This is a VERY IMPORTANT peripheral to have in your system. It allows the Nios II development 

tools to validate that the software application is being built for the correct hardware system. 
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 From the IP Catalog menu, select Basic Functions -> Simulation; Debug and Verification -> 
Debug and Performance -> System ID Peripheral. Double click to add the component to the system. 

 The sysid dialog box appears. Click Finish. 

 Rename as “sysid”.  The component must be named “sysid” to be compatible with Nios II software 
drivers and build tools. 

  Change the connection on the control_slave port of the peripheral to be connected to the m0 master 
port of the slow_periph_bridge.   

 In the clock column, select sdram_pll_40 as the clock for the clk Clock Input 

 

 

 

5.4 System Configuration 

1.  Clock source for each component 

We need to confirm the clock source for each of the components such that only the PLL has clk_50 

selected in the Clock” column and that the nios2_cpu, onchip_ram, 

BeMicro_Max10_serial_flash_controller_0 and the s1 port of the slow_periph_bridge have sdram_pll_80 

selected for their clock sources.  The m1 port of the slow_periph_bridge and all remaining components will 

have sdram_pll_40 selected for their clock sources. 
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Ensure that your clock sources are configured as shown below.   

Make sure you connect the IRQs as shown below. 

Also, confirm that your connections are as shown in the connections column.  You may have missed the 

previous steps to modify these connections as you were adding the components.  

 

 

2. Create a Global Reset Network 

Qsys provides the flexibility to connect individual resets to each of the components in the system. For our 
system, we simply want all components tied together.  QSys provides an easy menu item to do exactly this 
and will save us from having to manually connect the reset inputs to each component.  

 From the System menu, choose Create Global Reset Network. The tool will automatically connect all 
the resets in the system together. 
 

3. Set Base Addresses and Interrupt Priorities 

QSys provides two easy menu items that help clean up address map issues and interrupt priority issues.  
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 From the System menu, choose Assign Base Addresses. The tool will assign appropriate base 
addresses for the components by taking their widths into consideration. 

 From the System menu, choose Assign Interrupt Numbers. The tool will update the IRQ mapping 
accordingly. 

 
At this point you should only be left with a couple of information messages and reminders that you have yet 

to specify the CPU reset and exception address configuration. 

4.  Nios II Boot Configuration 

In the event of a reset, the software must begin executing from a predefined memory location. This is set 

by setting the reset vector.  Similarly when a software exception event occurs the software must jump to a 

pre-defined location where the exception handling software resides. This location is set by setting the 

exception vector. 

 Double click on the cpu peripheral to launch the “Nios II Gen2 Processor (Preview)” Parameter 
Settings GUI. 

 Click on the Vectors tab. 

 Set the Reset Vector to point to the onchip_ram with an offset of 0x0. When the Nios II processor 
comes out of reset, it will begin executing software at this memory location. 

 Set the Exception Vector to point to the onchip_ram memory with an offset of 0x20. When the Nios II 
processor experiences software exceptions or interrupts, it will jump to this location in memory.  

 
  

Click Finish. 
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5.5 Export Connections 

Several peripherals contain connections to pins on our device, which means that we need to “export” those 

connections out of QSys.  QSys provides an Export column in which we can select which interfaces will be 

available for connections outside of this QSys block.   

We need to export the following interfaces by double-clicking in the Export column and then renaming the 

export name to match exactly so that the names of those signals match the top-level Verilog or VHDL file 

provided with this lab. 

Component Port to be exported Export Name 

sdram_pll 
 

c1 sdram_pll_80shift 

areset_conduit sdram_pll_areset_conduit 

locked_conduit sdram_pll_locked_conduit 

phasedone_conduit sdram_pll_phasedone_conduit 

adc_pll areset_conduit adc_pll_areset_conduit 

phasedone_conduit adc_pll_phasedone_conduit 

sdram wire sdram 

serial_flash_controller external serial_flash 

spi_accelerometer external spi_accelerometer 

spi_dac external spi_dac 

led_pio external_connection led_pio_external 

button_pio external_connection button_pio_external 

i2c_temp_sense export i2c_temp_sense 

 
If you accidentally double-click into the wrong cell, you will need to delete the name complete to remove the 
export. 
You can confirm your connections above by looking on the following page and comparing to the screenshot of 
the completed system.  
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This concludes the system configuration. At this point you should have addressed all the system validation 

issues and can now generate the QSys System.  To get the following view: Right click on any  component: 

Select -> Filter -> Hide Clock and Resets. 

THE RESULTING QSYS SYSTEM 
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5.6 Generate the System 

Please Double-check to make sure that all the component names in your QSys system match 
the component names shown above.  Do not worry if the base and end addresses do not match 
exactly. 

Select: Generate -> Generate HDL, then click the Generate button. If it asks you to save select Yes. 

 

QSys will now create: 

 The HDL for the various components in your system 

 System interconnect to connect the components together 

 System description file used by the Nios II software development tools (the Nios II SBT) to build 
the software project 

The HDL generate process will take a couple minutes.  Once your system has been successfully 
generated you will see the info message “Info: System generation was successful”.    
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In the “Generate Completed” dialog box, there will be a message that “Generate: completed with 

warnings.” Click on the  button to filter on just the warning message.  You should have just the 
following 2 warnings: 

 

Exit QSys by going to the File menu and choosing Exit. Click Save if it asks if you’d like to save the 
system. 

CONGRATULATIONS!! You have just built your first QSys system! 
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6. COMPLETE THE QUARTUS II PROJECT 

Module Objective 

In this module you complete the Quartus II project by adding the generated QSys system to the top-level 
entity. Compile in the Quartus II software to perform analysis, synthesis, fitting, place and route as well as 
timing analysis. At the end of the compilation, an FPGA image or SRAM object file (*.SOF) will be 
generated. The FPGA image can be downloaded to the BeMicro Max 10, at which point the on-board 
FPGA will function as a processor custom-made for your application. 

6.1 Add the System’s IP Variation File to the Quartus Project  

You will now return to the main Quartus II window and should receive the following message about an 
IP Variation file.  

 

An IP variation file is a file with extension of *.qip that is generated by QSys systems (or also by 
standalone IP Catalog block).  The *.qip file keeps track of the generated files so that your Quartus 
project can know what files are needed for FPGA compilation. 

 To add the nios2_bemicro_system.qip file, go to the Project menu and select Add/Remove Files 
in the Project… You will be taken to a dialog box with a list of project files.   Click on the … button 
to the right of “file name”.   
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 Double click into the nios2_bemicro_system folder and then double click into the synthesis folder 
and select the “nios2_bemicro_system.qip” file and click “Open.” 

 
 The file will now be listed next to “file name:” Click the Add button to add the file to the file 

listing.

 

6.2 Set up the Quartus II Project to point to the proper timing constraint files 

Reason:  Similar to ASIC design, FPGAs require timing analysis since routing within the FPGA device 

will vary based on where the Quartus II Fitter places the logic.  Entering timing constraints will provide 

the Quartus II Fitter with design goals to make intelligent choices about where to place the logic and 

other elements in the design and then will provide the Quartus II TimeQuest Timing Analyzer with 

information so that it can report whether we have met our timing goals.  The constraints are coded in an 

industry standard language called SDC (Synopsis Design Constraints). 

QSys automatically generated SDC files for components which provide timing information.  In our 

system, only the Nios II CPU has generated SDC files.  In addition, an SDC file called 

bemicro_m10_nios2_top.sdc is included with the lab files and instructs TimeQuest to determine our 

clock rates by analyzing the PLL.  We must set up our Quartus project to point to these SDC files. 

 From the Assignments menu in the Quartus II software, select Settings. 
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 Expand Timing Analysis Settings and select TimeQuest Timing Analyzer 

 In the “SDC files to include in the project” click on the “…”  

 In the Select File dialog box, navigate up two level to return to the 
bemicro_m10_embedded_lab_14_0 project directory and select the bemicro_m10_nios2_top.sdc 
file found in the project directory, then click Open.   

 
 

 Click on the “Add” button to add it to the list of SDC files. 

 
 Select "OK" to exit the Settings dialog box. 
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At this point the design is ready for compilation. 

 Click the Start Compilation button on the Quartus II tool bar. 

 

The Quartus II software will take a few minutes to compile the design. There should be no errors in the 

compile, and you should see the successful completion dialog when it is finished.  You will see some 

warnings that relate to the files from the automatically generated system, missing assigments/features 

and incomplete pin assignments but these will not affect the functionality of the system.   

The output of the compilation is a SOF file entitled “bemicro_m10_nios2_top_time_limited.sof” if you do 
not have a license for the Nios II processor. (If you do have a license for the Nios II processor, the file 
will be named “bemicro_m10_nios2_top.sof”.) 

6.3 Download the FPGA configuration 

Ensure that your BeMicro Max 10 kit is plugged into your computer’s USB port and launch the Quartus 
II Programmer to configure the FPGA. 

 Click on the Programmer icon on the Quartus II desktop, or alternatively open the Programmer 
from the Tools menu. 

 

 In Quartus II Programmer click Hardware Setup. In the Currently selected hardware drop box 
select USB-Blaster.  Click Close.  

 In the Programmer window, click the “Add File…” button. 

 Browse into the output_files directory to locate the bemicro_m10_nios2_top_time_limited.sof 
programming file, select the file and click Open. 



Complete the Quartus II Project 
 

BeMicro Max 10 Getting Started User Guide, Version 14.0 54 
 

 
 

 Unless you have a license for the Nios II processor, you will obtain a message about a time-limited 
megafunction. This message indicates that since you do not have a license for the Nios II processor, 
operation will occur in “OpenCore Plus” evaluation mode.  OpenCore Plus allows for tethered or 
time-limited evaluation prior to purchasing a license. 

o PLEASE NOTE: OpenCore Plus evaluation mode prevents us from programming the flash of 
the MAX 10 device and evaluation must occur by programming the FPGA from the Quartus II 
Programmer each time the kit is powered up. 

 Click OK to acknowledge the message. 

 

 After selecting your SOF file, click on the Program/Configure checkbox. 

 Press the Start button to program the FPGA. 
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After programming the FPGA the progress indicator should indicate 100% complete, and there should 
be no error messages displayed.  

NOTE: If you do not have a license for the Nios II processor then your system would have generated 
the Nios II in OpenCore Plus evaluation mode and your SOF programming file will be time-limited.  If 
you are running with a time-limited SOF file, then this window pops up on the Quartus II Programmer.  

 

Just leave this up and do not press “Cancel” until you are finished using the hardware design that you 

just downloaded. Closing this dialog will halt the Nios II CPU inside the FPGA. 

CONGRATULATIONS!!  

You have just compiled and downloaded the FPGA image onto the target. The processor is ready to 

run, so all you need to do now is develop the software application and download it to the target. 
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7. BUILD THE SOFTWARE APPLICATION 

Module Objective 

In this module you use the Nios II Software Build Tools (SBT) for Eclipse to develop the software application 

that will run on your system. You will create a new software application project, add the software source files to 

the project, configure the project and build it. The result of the build is an executable (ELF). The application will 

be downloaded into memory from where it will be executed. 

7.1 Launch the Nios II Software Build Tools for Eclipse 

Launch the Nios II SBT from the Start -> All Programs -> Altera 14.0.0.200 Web Edition -> Nios II 

EDS 14.0.0.200 (64-bit) -> Nios II 14.0 Software Build Tools for Eclipse or alternatively it can be 

launched from the QSys -> Nios II menu. 

1. Initialize Eclipse workspace 

When Eclipse first launches, a dialogue box appears asking what directory it should use for its 

workspace.  It is useful to have a separate Eclipse workspace associated with each hardware project 

that is created in QSys.  

 Browse to the directory that you created the Quartus II project in and click Make New Folder to 
create a folder for your software project. Name the folder “eclipse_workspace”. 

  
After selecting the workspace directory, click “OK” and Eclipse will launch and the workbench will appear in the 

Nios II perspective. 
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7.2 Create a new software project in the SBT  

Select File -> New -> Nios II Application and BSP from Template. 

 

 To set the QSys Information File, click the Browse button to locate the 
nios2_bemicro_system.sopcinfo file located in the Quartus II project directory. 

 Set the name of the Application project to “bemicro_m10_lab”. 

 Select the Blank Project template under Project Template. 

 Click the Finish button. 

 

The tool will create two new software project directories 
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Each Nios II application has 2 project directories in the Eclipse workspace. 

a. The application software project itself - this where the application lives. 

b. The second is the Board Support Package (BSP) project associated with the main application 
software project. This project will build the system library drivers for the specific QSys system. 
This project inherits the name from the main software project and appends “_bsp” to that. 

 

Initial content of the project 

Since you chose the “blank” project template, there are no source files in the application project 

directory at this time.  The BSP contains a directory of software drivers as well as a system.h header 

file, system initialization source code and other software infrastructure. 

7.3 Add source code to the project 

In Windows Explorer locate the project directory which contains a directory called 

“software_source_files” which contains a directory called “bemicro_led_control_src”. This directory 

contains an “inc” directory, “src” directory and “main.c” file.  You will copy these files and directories 

from Windows Explorer into the Eclipse software project directory, “bemicro_led_control”. 

 Select the 3 files and drag them over the “bemicro_led_control” directory in the SBT window and 
drop the files onto the project folder. 

 

 This should cause the source files to be physically copied into the 

file system location of the software project directory and register 

these source files within the Eclipse workspace so that they 

appear in the Project Explorer file listing. 

 Select: OK 
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7.4 Configure Board Support Package 

 Configure the board support package to specify the properties of this software system by using the BSP 

Editor tool. These properties include what interface should be used for stdio and stderr messages, which 

memory should stack and heap be allocated in and whether an operating system or network stack should 

be included with this BSP.  

 Right click on the bemicro_led_control_bsp project and select Nios II -> BSP Editor… from the right-
click menu. 

 

The software project provided in this lab does not make use of an operating system. All stdout, stdin and stderr 

messages will be directed to the jtag_uart. The auto-generated linker script will be used and the various linker 
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sub-sections (Program memory, Read-only data memory, Read/write data memory) will be stored into 

onchip_ram. We will point the linker to place the heap and stacks in onchip_ram memory. 

In the “Common” settings view, change the following settings: 

 Confirm that the timer peripheral is selected as the hardware for the sys_clk_timer. 

 Select the timer peripheral as the hardware for the timestamp_timer. 

 Select the onchip_ram is selected as the linker target for both the 
exception_stack_memory_region_name and the 



Build the Software Application 
 

BeMicro Max 10 Getting Started User Guide, Version 14.0 61 
 

interrupt_stack_memory_region_name.

 

You may wish to click on the Drivers tab to observe how the BSP Editor gives you control over what drivers 

will be built into your Board Support Package.  Similarly, you may wish to look over the Linker Script tab to 

observe how the BSP Editor provides you with a mechanism to adjust what memory regions the linker will 

utilize.  In the case of this lab, we have only one volatile memory in the system, but for systems with multiple 

memories, this is a handy tool. 
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 Select File -> Save to save the board support package configuration to the settings.bsp file. 

 Click the Generate button to update the BSP. 

 When the generate has completed, select File -> Exit to close the BSP Editor. 

7.5 Configure BSP Project Build Properties 

In addition to the board support package settings configured using the BSP Editor, there are other compilation 

settings managed by the Eclipse environment such as compiler flags and optimization level. 

 Right click on the bemicro_led_control_bsp software project and select Properties from the right-click 
menu. 

 On the left-hand menu, select the Nios II BSP Properties tab 

 During compilation, the code may have various levels of optimization which is a tradeoff between code size 
and performance.  Change the Optimization level setting to Level 2. 

 To keep the software footprint compact, choose Reduced device drivers. 

 Since our software does not make use of C++, uncheck “Support C++”. 

 

 Click Apply. Click OK. 
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7.6 Configure Application Project Build Properties 

Just as you configured the optimization level for the BSP project, you should set the optimization level for the 

application software project “bemicro_led_control” as well. 

 Right click on the 
bemicro_led_control software project 
and select Properties from the right-
click menu. 

 On the left-hand menu, select the Nios 
II Application Properties tab 

 Change the Optimization level setting 
to Level 2. 

 Click Apply. Click OK. 

 

7.7 Build the software project 

 Right click the bemicro_led_control_bsp software project and choose Build Project to build the board 
support package. 

 When that build completes, right click the bemicro_led_control application software project and choose 
Build Project to build the Nios II application. 

These 2 steps will compile and build the associated board support package, then the actual application 

software project itself. The result of the compilation process will be an Executable and Linked Format file for 

the application, the (*.elf) file.  
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7.8 Run the software application on the target 

To run any application on the target hardware, two images are needed 

 The FPGA hardware image SRAM Object File <.SOF>. 

 The software executable the <.ELF>.  

In the previous module you already downloaded the .SOF, so the FPGA is primed and ready to run the  

software application. Keeping the BeMicro kit still plugged into the USB port, you will download the application 

via the USB-JTAG link. To run the software project on the Nios II processor: 

 Right click on the software project directory and choose Run As and Nios II Hardware.  
Note: Do not select Nios II Hardware v2 (Beta). 
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This will re-build the software project to create an up–to-date executable and then download the code into 

memory on our BeMicro hardware. The debugger resets the Nios II processor, and it executes the downloaded 

code. 
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7.9 Software Application Output 

Once the application starts executing, it will relay the messages back to the Nios SBT via the JTAG UART 

interface and the messages from this interface will be placed into a new “Nios II Console” pane within the 

Eclipse GUI. Eclipse places this console in a somewhat inconvenient location on the right of the window which 

is too narrow for viewing our console output properly.  You will need to move this pane to another portion of the 

Eclipse GUI, resize the pane or maximize the pane in order to see the full console output.  An example of how 

to move the pane is shown below. 
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If the application is executing successfully, the console output should appear as shown below: 
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6.8  Interact with the Software Application 

Once you have the bemicro_led_control application running on the Nios II processor, you can interact with the 
demo by using your keyboard to control the program flow. 

6.9 Edit the Application 

You can optionally modify the led_util.c source file to change the software such that the counting LEDs are 
inverted.  

 Open the file led_util.c and locate the following subroutine: 

update_ledg( ) 

 In the beginning of the subroutine add the following line:  
display_value = ~ display_value; 

Once this is rebuilt, the application can be rerun to see the change in LEDs. 

CONGRATULATIONS!!  

You have just built the software application, downloaded it to the target and run the application 

on the target. 
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TAKING THE NEXT STEP 

After you have sufficiently familiarized yourself with the embedded system development flow, you may want to 

add a QSys system to your design.  

If you are starting from scratch, a good idea is to purchase a Nios II development kit, which comes with pre-

generated Nios II processor systems to accelerate your development flow as well as the Nios II IP license. 

If you already have a working project then you can add the QSys system to your top level as a stub or even 

add your design to the QSys system as a custom component.  

Either way you will find plenty of resources to get your job done on Altera’s embedded resources at 

www.altera.com/embedded 

Purchase an evaluation or development kit 

Embedded Development Kit Resources 

http://www.altera.com/products/devkits/embedded-index.jsp 

Get more information about the Nios II Processor 

 The Nios II Processor Reference Handbook 

 http://www.altera.com/literature/hb/nios2/n2cpu_nii5v1.pdf  

Get more information about the Nios II Software Development Tools 

 The Nios II Software Developers Handbook 

 http://www.altera.com/literature/hb/nios2/n2cpu_nii5v1.pdf  

Get more information about Embedded System Design 

 Embedded Design Guide 

 http://www.altera.com/literature/hb/nios2/edh_ed_handbook.pdf  

Get more information about QSys and Embedded IP Peripherals 

 QSys (Quartus II) Handbook  

 http://www.altera.com/literature/lit-sop.jsp  

Get Ready made Nios II Processor System Design Examples and Software Applications 

 Nios II Design Examples page  

 http://www.altera.com/support/examples/nios2/exm-nios2.html  

Get Free Online Tutorials or take an In person training course 

 Embedded Training Resources 

 http://www.altera.com/technology/embedded/training/emb-training.html  

http://www.altera.com/embedded
http://www.altera.com/literature/hb/nios2/n2cpu_nii5v1.pdf
http://www.altera.com/literature/hb/nios2/n2cpu_nii5v1.pdf
http://www.altera.com/literature/hb/nios2/edh_ed_handbook.pdf
http://www.altera.com/literature/lit-sop.jsp
http://www.altera.com/support/examples/nios2/exm-nios2.html
http://www.altera.com/technology/embedded/training/emb-training.html
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Get support for your development by joining the Altera Forum 

 Included is a Nios II User Forum 

 http://www.alteraforum.com/ 

For all resources visit http://www.altera.com/devices/processor/emb-index.html 


