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Introduction
This tutorial will present a step-by-step walk-through of some bare-metal examples and then use the built-in Linux-based SoC FPGA example system.
For the initial bare-metal usage, there will be examples of how to create and debug bare-metal projects within the Altera SoC Embedded Development Suite (EDS).
The Altera SoC EDS includes the DS-5 Altera Edition.
This useful toolset allow you to create a bare-metal application within the IDE and configure it and run it on an Altera SoC target board.  It also includes tools to help build the software system and create the flash image for the board.
This Hands-On Session will include :
· Part 1: Bare-metal
[bookmark: _Toc431907836]Part 1: Bare-metal
The three general steps that are involved in bare-metal debugging on the Altera Cyclone V SoC-based target board are as follows:
· Create a bare-metal application project within DS-5 Altera Edition
· Build this project
· Create a debug configuration to download and run the application
These three steps are all that is required to run simple bare-metal example applications within the on-chip RAM (OCR).
After completing this simple example, we will expand upon this to show how to enable the external memory controller and then create and run an example within the external memory and then importing a more complicated example that also interacts with the FPGA.
DS-5 Altera Edition project manager is configured to offer a choice of  either the ARM compiler or an Altera GCC-based compiler for bare-metal projects.  In this session we will create some simple bare-metal projects that use the ARM compiler.
The progression is as follows:
1. Setup and configure that target board
2. Create, load and debug a simple bare-metal project using the ARM compiler and on-chip RAM
3. Modify the simple bare-metal hello world project to use SDRAM, then build, load and debug it
4. Import an existing bare-metal project that uses HWLibs and the FPGA



[bookmark: _Toc431907837]Setup and configure the target board
For this tutorial, the Atlas-SOC board will be used.  
[image: http://www.terasic.com.tw/attachment/archive/941/image/image_80_thumb.jpg]
This is a great low-cost starter board that makes use of the Altera Cyclone V SoC.  It has a built-in USB Blaster II JTAG debugger which will be used to download and debug the bare-metal examples.
Unpack the board, cables and power supply.
Make sure that the FPGA Configuration Mode (MSEL) switch settings are correct for FPPx32 (HPS: OS).
	Configuration
	SW10.1
	SW10.2
	SW10.3
	SW10.4
	SW10.5
	SW10.6
	FPGA configuration source

	
	MSEL0
	MSEL1
	MSEL2
	MSEL3
	MSEL4
	 
	

	AS
	ON
	OFF
	ON
	ON
	OFF
	N/A
	EPCS

	FPPx32 (default)
	ON
	OFF
	ON
	OFF
	ON
	N/A
	HPS: OS (Linux default)

	FPPx16
	ON
	ON
	ON
	ON
	ON
	N/A
	HPS: U-boot (image stored on SD card)



Connect the USB mini-B cable to the USB Blaster II port near the power supply connector (shown on the left side in the figure above.  This JTAG debug connection is the only required communication connection to download and debug bare-metal applications.
Do not plug in the power supply until you are ready to begin using the target board.  Temporarily remove the boot SD/micro card located on the reverse side of the board by pressing it.  Keep in in the socket but not plugged in.
Launch DS-5 Altera Edition as follows:
· Select from the Program Group “Altera 15.1.0.179->SoC Embedded Design Suite (EDS) 15.1.0.179 Command Shell”.  
· Note that the last digits (in this case 179) indicate the revision and may vary depending on the current revision.
· Launch DS-5 Altera Edition by typing “eclipse &” into the command shell.

[image: ]
If queried to select a Work Space, enter “C:\ASDF\DS-5 Workspace”. 
[image: ]
 The Welcome Screen will look like similar to the following screen.
[image: ]
Close the Welcome Screen by clicking the [image: ]  to the right of “Welcome to DS-5”.[image: ]
We will be using the Project Explorer view (on the left side) to create, manage, run and debug a number of example projects. 
The following example creates a “hello world” bare metal application.  We will use the “Hello World” example type, which pre-populated the project with a simple hello world program.  If you are interested in creating this project from an Empty Project instead, then follow the instructions in Appendix A “Creating hello-world project from an Empty Project”.
[bookmark: _Toc431907838]Example 1: Simple “hello-world” bare-metal project using on-chip RAM	
In this example we will create, build, load and debug a simple “hello world” application project. 
If it is not already selected, change to the C/C++ Perspective [image: ] (top right tabs of DS-5).
Select File->New->Project->C/C++ Project->C Project.
From the Executable options select “Hello World ANSI C Project”.
Select from Toolchains: option “ARM Compiler 5 (DS-5 built-in)” if it is included.[image: ]
Enter a name in the “Project name” field, and then select “Finish”.  Do not use spaces in the project name.  Hyphens (dashes) or underbars work better.
The newly created project will appear in the Project Explorer view.
[image: ]
Right click on the new project, in this case “hello-world” and then select “Build Project”.
[image: ]
This will create and build the project and create the “Debug” directory and it’s contents, and show the progress in the Console view at the bottom.[image: ]
Switch to the Console view to see the details of the build[image: ]
According to the error messages, the cpu has not yet been selected.  Right-click on the “hello-world” project and select Properties, then C/C++ Build->Settings and under the Tool Settings tab, select ARM C Compiler 5->Target and fill in the “Target CPU (--cpu)” field with “Cortex-A9”.
[image: ]
Select Apply and OK.
Right click on the project and select “Build Project”.    The error messages should be gone.[image: ]
Create scatter file
The project has now been created and built using default linker settings.  To link and locate the code for the target under test it is necessary to create a linker file or script.  In the case of the ARM Compiler this is called a scatter file.  
Right click on project, select “New->Other…” Then “Scatter File Editor->Scatter File”.[image: ]
Select the project name, for example hello-world, and then enter a name for the new scatter file for example “scatter_OCRAM.scat”.  
[image: ]
Select Finish.
Sometimes a new file may not automatically show up in the Project Explorer view, for example if the file was created or copied from outside of the DS-5 environment.  To refresh the contents of the project, and show any new files, click somewhere in the Project Explorer and hit F5 to refresh the project file list.
After creating the new scatter file, it will bring up an empty scatter file editor view for the new file scatter_OCRAM.scat.   In the editor view, enter the following:
OCRAM 0xFFFF0000 0x10000 ; 64K On-chip RAM
{
    APP_CODE +0
    {
        * (+RO, +RW, +ZI)
    }
    ARM_LIB_STACKHEAP  0xFFFF8000 EMPTY  0x8000 ; Application heap and stack
    { }
}
The view will then look similar to the following:
[image: ]
Notice the asterisk to the left of the new file name “*scatter_OCRAM.scat”.  As with other editor views in DS-5 AE, this indicates that the file has not yet been saved.  Save the file by selecting File->Save (or <ctrl> S). 
[image: ]
Select the “Regions/Sections” tab just below the scatter file to show what the memory map looks like.
[image: ]
Although the scatter file has been created in the project, it has not yet been implemented.  To associate the scatter file with the project, right-click on the project and select Properties and then navigate to ARM Linker 5->Image Layout and browse to the file or enter the path in the “Scatter file (--scatter)” field  for example “${workspace_loc}\hello-world\scatter_OCRAM.scat”.
[image: ]Select Apply, and then OK.  Then rebuild the project. [image: ] 
If the build does not succeed and shows errors similar to the following:
Error: L6221E: Execution region APP_CODE with Execution range [0xffff0000,0xffffa454) overlaps with Execution region ARM_LIB_STACKHEAP with Execution range [0xffff8000,0x100000000).
then you may have tried to create a C++ project instead of C project.  Try creating the project again but specify “C Project “instead of “C++ Project”.
[bookmark: _Toc431907839]Downloading and debugging the project.
Connect the target board to the computer through the mini-USB cable to the port marked USB Blaster which is located near the power supply connector.
Create a Debug Configuration to use for this project.  To do so, bring up the Debug Configuration window.  For future reference, when the instructions refer to the Debug Configurations window, then open the Debug Configurations window by selecting Run->Debug Configurations from the top menu.  The Debug Configurations window looks like this.
[image: ]
Click once on DS-5 Debugger to highlight it.  Then select the [image: ] icon at the top-left to create a ‘New’ configuration.
It will open a Debug Configuration editor window to “Create, manage and run configurations”.  Notice in this window, that there are tabs under the “Name:” text field on the right.  We will be adjusting the settings in the Connection tab, Files tab, and Debugger tab. 
Select the Connection tab.  In this window, the debug connection to the target board is specified.[image: ]
Type “Cyclone” into the “Filter platforms” text field to trim the list.  Then select Altera->Cyclone V SoC (Dual Core)->Bare Metal Debug->Debug Cortex-A9_0 .  Also select make sure that “USB-Blaster” is selected in the “Target Connection” pull-down menu.  

[image: ]
Select Browse to the right of the Bare Metal Debug field below “Connections”.
[image: ]
[image: ]
Select Apply.
Click on the Files tab (in the Debug Connections window).  This is located just to the right of the Connection tab as shown below.
[image: ]
Then select Workspace to browse to the executable file hello-world.axf which can be found in the “hello-world” project under the Debug folder.
[image: ]
Make sure that “Load symbols” is checked and then select Apply.[image: ]
Change the name of the debug configuration from “New_configuration” to something like “hello-world”.  Do not use spaces in the name.  
Select “Apply”. 
Go to the Debugger tab, and select “Debug from symbol “main” and select Apply.
[image: ]
When you are ready to download and debug the program select “Debug”.
If queried to open the DS-5 Debug perspective, select “Yes”.
[image: ]
Windows Firewall may ask if the debug connection is allowed.  If so, select all networks and then “Allow access”.
[image: ]

DS-5 AE will switch to the DS-5 Debug perspective and download and launch the program. 
The debugger perspective should look like the following:
[image: ]
If it does not look similar to the above screen, then check the following possible problems.
If there is an error connecting to the debug connection similar to the following:
[image: F:\errors\localhost-error.png]
There is chance that the selection from the Debug Connection->Connection->Select Target
Adjust or recreate the Debug Configuration and try it again.
If it does not indicate that the status is “connected” and “stopped on breakpoint” and the Debug Connection status is “connected (waitForTargetToStop)” and “running” as shown in the following screen, then there is a good chance that the target is already running.  For example if the SD/micro card was not disabled and the target continued to boot Linux.

[image: ] 
If the target appears to be running instead of stopped as shown above, unplug that target, make sure that the SD/micro card is removed or unplugged, and then plug in the power again.  Select the Disconnect icon [image: ] in the Debug Connection, then click on the “Connect to Target” icon [image: ] and it should repeat the process of downloading and running the application correctly.
If all is well the program runs and hits a temporary break-point at main().  Make sure that the “App console” is showing in the bottom right so that you can see the output messages.  Click on step over [image: ] a few times to walk through the program. Other source debugging options ([image: ] ) are also available on the “Debug Control” window.
[image: ]

Select “Continue” [image: ] or <F8>.
[image: ]
Run the program again by selecting the “Debug from main()” icon [image: ].
Disconnect from the target by selecting [image: ]
[image: ]
After disconnecting, you can repeat the debug launch sequence exactly by selecting the Debug Connection (in this case “hello-world disconnected”, and then selecting the “Connect to Target” icon [image: ].  For this reason it is sometimes very useful to keep the connection listed in the Debug Connections list.  However to remove the connection from the Debug Connections list, select the debug configuration “hello-world disconnected” and then click on [image: ].
[image: ]
Switch back to the C/C++ perspective by selecting the C/C++ perspective icon [image: ] from the top-right to the left of the Quick Access field.  For future reference, you can switch back to the DS-5 Debug perspective by selecting the corresponding icon [image: ].
[bookmark: _Toc431907840]Example 2: Modify the project to run from external SDRAM memory
After completing the process of creating a simple hello world application and downloading and debugging it in on-chip RAM of the Altera SoC, the next step is to configure the same project to run in SDRAM instead of on-chip RAM.
[bookmark: _Toc431907841]Create a new scatter file to locate in the SDRAM area
In the DS-5 ARM compiler projects it is the scatter file that specifies the addresses that are used to locate the code in the required portion of the memory map.
In this step you will use the same hello world application, but build it located in the SDRAM memory instead of the on-chip RAM.  To use SDRAM, you must run the Preloader to configure the SDRAM memory controller.  
First, create a scatter file for SDRAM.  If you are still in the DS-5 Debug perspective, then switch back to the C/C++ perspective by selecting the “C/C++” perspective button to the right of the “Quick Access” field near the top right.   Create the new scatter file for use with SDRAM.  It’s easy to edit the previous scatter file and save it with a different name.  Double click on the scatter file that was created for on-chip RAM to open it and modify as follows:
Two lines are different between the scatter files.  The resulting scatter file should look like this:

SDRAM 0x02000000 0x02000000 ; 32m SDRAM
{
    APP_CODE +0
    {
        * (+RO, +RW, +ZI)
    }
    ARM_LIB_STACKHEAP  0x03000000 EMPTY 0x01000000 ; Application heap and stack
    { }
}

[image: ]

Save the scatter file using the “Save As” option in the project area with a new name, for example “scatter_SDRAM.scat”.
[image: ]
Refresh in the Project Explorer <F5> if necessary to view the new scatter file.
Associate the new scatter file with the project.
Right-click on the project and select Properties->C/C++ Build->Settings->ARM Linker 5->Image Layout”.  
[image: ]
Enter the path to the new scatter file:
${workspace_loc}\hello-world\scatter_SDRAM.scat 
Or use Browse to select the scatter file in the hello-world DS-5 Workspace Project.
[image: ]
Select Apply and then OK.

Right-click on the project and select Build Project to rebuild with the new scatter file.[image: ]
The bare-metal project is now built and linked and located in the external SDRAM.  However in order to use the external SDRAM, the memory controller must be configured.  If the SDRAM memory controller is not configured, then any attempt to use this memory will fail.  If this occurs, then reset the board by cycling the power to the board.
The Preloader can be used to configure the memory controller.  The Preloader is an initial program loader that is used to configure the external memory controller and then load an operating system or bootloader such as U-Boot.
Only the initial configuration part of the Preloader needs to be run to configure the external memory controller.
[bookmark: _Toc431907842]Loading and Running the Preloader
The Preloader is the boot-strap program that performs initial configuration of some key components of the board including the memory controller.  It would normally run automatically if it were burned into one of the Flash devices on the board.  For testing purposes or before the Preloader has been burned into Flash, the Preloader can be run by downloading and executing it from the DS-5.
In order to run any bare-metal applications in the external memory (SDRAM) it is necessary to configure the memory controller.  We use the Preloader serve this purpose.
Note that the Preloader needs to be run before launching any bare-metal example that uses the external memory.  For this purpose we will create a Debug Configuration to launch the Preloader.
There are a few options for running the Preloader.  It can be run via a DS-5 command script.  It can be imported into a DS-5 project and launched similarly to any other bare-metal application.  It can also be launched by the DS-5 Run Control (Debug Control) independent from the DS-5 projects.
While it is simple  to download and launch the Preloader independent from any DS-5 project by a debug configuration that specifies the full path to the Preloader image file to be loaded.  It is less redundant and easier to keep track if the Preloader is included in a separate DS-5 project. 
You can create this project from scratch by following the instructions in Appendix A “Creating the Preloader Project from scratch” or import it to save some time.
Import the Preloader project into your Workspace as follows:
Select File->Import, then select “Existing Projects into Workspace” as shown.
[image: ]
[image: ]
Check “Select archive file” and “Browse” to the “RunPreloaderAtlas.tar.gz” file in the C:\ASDF\Examples directory.
 [image: ]
Select “Open”.
[image: ]
Select “Finish” to import the project.[image: ]
Expand the imported RunPreloader Project folder to show the contents.
If the Target Debug Connection and USB port happen to be correct, then this Debug Configuration can be run by right clicking on the “RunPreloader.launch” debug configuration listed in the Project Explorer, and select Debug As->RunPreloader.[image: ]
If configured correctly then this will launch the program and bypass the Debug Configuration Editor view.  If you encounter an error with connecting to the debugger, then there is a good change that the USB port in the Debug Configuration needs to be changed.  If no error, then skip to “Switching to the DS-5 Debug Perspective.”  If there is an error message, then perform the following steps:
Select Run->Debug Configurations.  Select the newly imported debug configuration named “RunPreloader” by clicking on it.  [image: ]
Then click on the “Browse” button to the right of the “Bare Metal Debug” field to select from the available debug connections and corresponding USB port. 
[image: ]
Click the “Select” button.  Then select “Apply” and then “Debug”.
Switching to the DS-5 Debug Perspective.
If asked to switch to the DS-5 Debug perspective then select “Yes”.
[image: ]
This Debug Configuration will run the initial configuration portion of the Preloader and then stop and wait.[image: ]
This Debug Configuration can now be reused to launch the Preloader any time.  It should load and run the Preloader in the on-chip RAM similar to how the simple bare-metal hello-world example was run with the OCRAM scatter file.  This Preloader bare-metal application will initialize the SDRAM memory controller and then stop and disconnect.
Although this method associates the Preloader image with a particular DS-5 project, it can be still used with other projects.
It is not necessary to delete the Debug Configuration from the list after it completes.  Although the status is disconnected, it is useful to keep this RunPreloader configuration in the Debug Configurations list so that is it simple to run it any time the board is reset or the power is cycled.
To run it again from the Debug Configurations view, select “RunPreloader disconnected”, and then select the “Connect to Target” icon [image: ].  
After that, you can download and run the hello world example or any other example in the SDRAM memory.  To run the hello-world example in the external SDRAM, the same Debug Configuration created earlier for the “hello world” example can be reused.
To launch the hello world program using the previously created Debug Configuration, select Run->Debug Configurations and then select the same “hello-world” debug configuration from earlier.  Please remember that the RunPreloader debug configuration must be run before any Project can be run in the SDRAM external memory.
[image: ]
As you can see, the program is now executing from the external memory (0x02000000), instead of the on-chip RAM from earlier (0xffff0000) which would have been impossible if the memory controller were not configured.
Click on the “Step Over Source Line” icon (or <F6>) to see the program counter progress to the next source line.
Click it again to see the “Hello World” message in the App Console view.  If the App Console view is not currently selected, then it will highlight in bold letters to indicate that there is a message.  Select the App Console view to see the output.
[image: ]
Select “Continue” to finish executing the program.
[image: ]
To rerun the same thing, select the debug connection from the list in the Debug Control view in this case “hello-world” and then click the yellow arrow [image: ].   This will run the same debug configuration again (and run from Main).  
When you have finished with this application, you can disconnect it from the target.  To disconnect, select the listed debug connection, in this case “hello-world application exit: code 0” and then click on the “Disconnect from Target” icon [image: ].
 [image: ]
It is not necessary to remove the disconnected debug connection from the Debug Control view however it can be removed since it only needs to run once.  If you do not remove a disconnected Debug Connection, then you can re-launch the configuration by selecting it from the Debug Control view and clicking the “Connect to Target” icon above it.
Don’t forget that if you reboot the board then you will need to run the Preloader to configure the memory controller before running an application in SDRAM.  One quick way to do this is to keep the disconnected debug connection in the Debug Control view.  Then select it and click on “Connect to Target”.  It will reproduce the previous launch.
When you’re completely finished with this application, you can remove it from the Debug Control view.  The connections must be disconnected in order to remove them.  To disconnect, select the Debug Connection and then click on the “Disconnect from Target” icon [image: ].  Once disconnected, you can select “Remove Connection” [image: ].
After removing the Debug Connection from the Debug Control view, rerun the Preloader by using the RunPreloader Debug Configuration.  Rerun the demo, using the Debug Configuration that was created for the hello-world application.
[bookmark: _Toc431907843]Example 3: Importing an Existing Bare-Metal Project in to DS-5
In this section we will import an existing project into the DS-5 Project Manager and then build and debug it.  This project makes use of the Bare-Metal Hardware Libraries (HWLibs) to program and run the FPGA and then interact with it.
There are a number of examples in the following directory:
C:\Altera\15.1\embedded\examples\software
These examples are setup for the Altera Cyclone V SoC Dev Kit.  They can be reconfigured for the Atlas SoC board.  The example Altera-SoCFPGA-HardwareLib-FPGA-CV-ARMCC.tar.gz has been edited to work with the Atlas SoC board and has been provided in the C:\ASDF\Examples directory.
If you are interesed in understanding what is required to change the default example to work on the Atlas SoC board, refer to Appendix A.
Import the example project as follows:
Select  “File->Import->General->Existing Project into Workspace”
[image: ]
[image: ]
Next to “Select archive file”, browse to the project archive: 
C:\ASDF\Examples\Altera-SoCFPGA-HardwareLib-FPGA-CV-ARMCC-Atlas.tar.gz
[image: ]
Select “Open”. 
[image: ]
Click on “Finish” to import the project.
Right-click on the project and select Clean Project.[image: ]
Select the “Console” tab to show the build details and then right-click on the project and select Build Project.
[image: ]
Make sure that the Preloader Debug Connection (RunPreloader) has already run since the last time the board was powered-down or reset.  If not, then run the Preloader by selecting Run->Debug Configurations->RunPreloader and then select Debug.  
After running the Preloader, right-click on the “Atlas-SoCFPGA-Hardware-FPGA-CV-ARMCC-Debug-Atlas.launch” Debug Configuration that was imported with the project.  This will launch the program.
[image: ]This will download and begin running the example program.  If you encounter an error connecting to the debugger, then select Run->Debug Configurations and then select the newly imported debug configuration “Atlas-SoCFPGA-Hardware-FPGA-CV-ARMCC-Debug-Atlas.launch”.  Browse to select from the available Bare Metal Debug connections.  Then “Apply” and “Debug”.
[image: ]
After successfully connecting to the target, hit will hit a temporary break-point on main() and then wait.
[image: ]
Set a break point at the call to “socfpga_bridge_io()”.  Search for the symbol using Find <ctrl>F.
[image: ]
Click on the line number in the editor view to set a breakpoint.
[image: ]
Select Continue to hit the break point.[image: ]
Step Source Line <F5> a few times, to step into the function.
[image: ]
[image: ]
As you step through the code, notice the variable (top-right) including the sysid returned from the alt_read_word() function. 
Continue again and then watch to see if the LEDs on the Atlas board light up.  If you are successful then you will see them light up in a pattern. The “App Console” window should also display results.
[image: ]
    The project includes a “readme.txt” file which describes more details about this example.

[bookmark: _Toc431907849]Appendix A:
[bookmark: _Toc431907850]Creating hello-world project from an Empty Project
The “hello world” project was a simple pre-canned example project.  To create this project from scratch, follow these steps.
Select File->New->C Project
[image: ]

Select Project Type: “Empty Project” and Toolchains: “ARM Compiler 5 (DS-5 built-in)” and enter a unique project name in the “Project name” field.  In this case “hello-world-from-scratch”.
[image: ]
Select Next, then Finish.
Highlight the project name and select New-Source File and give it a name, in this case “hello.c”.
[image: ]

When the file is presented in the editor view, enter the following code:
#include <stdio.h>
#include <stdlib.h>

int main(void) {
	puts("Hello World");
	return EXIT_SUCCESS;
}

Then Save the file.
After this point the project is essentially the same as the “Hello World” example project created in Example 1.

[bookmark: _Toc431907851]Creating the Preloader Project from scratch
You can import the Preloader image (u-boot-spl) into a DS-5 project somewhere within your workspace.  This makes it easier to reuse it with multiple projects and browse to it by clicking “Workspace” as shown below.  This would isolate your project from any changes that might be made to the default Preloader that is stored externally.
To do so, first create a general project.
[image: ]

Name it something like “Preloader”
[image: ]
Click Finish.
Import the Preloader into this project.  Right click on the project and select “Import”.  Then select “General->File System”.   
[image: ]
Browse to the directory that contains the Preloader (named: u-boot-spl) for the board that you are using or enter the full path to the directory, for example for the Atlas board that we are using, it can be found in c:\ASDF\Atlas
For the Cyclone V SoC Dev Kit it can be found in the following location:
C:\Altera\15.1\embedded\examples\hardware\cv_soc_devkit_ghrd\software\preloader\uboot-socfpga\spl
Check the box next to the file name and then select Finish.
[image: ]

Expand the Preloader project in the Project Explorer to show the newly imported file in the project.
[image: ]

Right click on the file “u-boot-spl” and select “Debug As->Debug Configurations”.  
[image: ]  Click on DS-5 Debugger and then click on the “New” icon just above the “type filter text” field.
Change the name of the Debug Configuration to something like “RunPreloader”.
From the Connection tab, select the target Altera->Cyclone V SoC (Dual Core)->Bare Metal Debug->Debug Cortex-A9_0”, select “USB –Blaster” for the Target Connection, and browse to the correct Bare-Metal Debug Connection and select “Apply.
[image: ]
On the Files tab, select Workspace and browse to the project and then select the Preloader file “u-boot-spl”.
[image: ]
Uncheck the check box next to “Load Symbols”
[image: ]

On the Debugger tab, enable “Execute debugger commands” with the following commands:
run
pause 1s
interrupt
quit

Then select “Apply”.
[image: ]
Notice that the “Debug” button is greyed out and cannot be selected.  The reason is explained at the top of the window “Debugging from a symbol, but no symbol files defined in the Files tab”.  Switch to the “Debug from entry point” option and then Apply the change.
[image: ]

Select Debug, to launch the Preloader and configure the board and memory controller, and then stop and disconnect, making the target ready to run a bare-metal application that makes use of the external SDRAM memory.


[bookmark: _Toc431907852]Modifying the Altera-SoCFPGA-HardwareLib-FPGA-CV-ARMCC example for the Atlas SoC board

Select  “File->Import->General->Existing Project into Workspace”
Next to “Select archive file”, browse to the project archive: 
C:\Altera\15.1\embedded\examples\software\Altera-SoCFPGA-HardwareLib-FPGA-CV-ARMCC.tar.gz
[image: ]
Click on Finish to import the project.
This example is configured for the Altera Cyclone V SoC Dev Kit board.  We will need to modify it for the Atlas SoC board.  To do so, open the file hwlib.c by double-clicking on the file in the Project Explorer.
[image: ]
Make the editor view full screen by double clicking on the tab labelled “hwlib.c”.  Use Find or <ctrl> F to search for the following definitions and change them to the Atlas version as follows:
ALT_LWFPGA_SYSID_OFFSET = 0x00010000; /* dev kit */
ALT_LWFPGA_SYSID_OFFSET = 0x00001000; /*Atlas SoC */
ALT_LWFPGA_LED_OFFSET   = 0x00010040;  /* dev kit */
ALT_LWFPGA_LED_OFFSET   = 0x00003000;  /* Atlas SoC */
Also since there are 8 LEDs on the Atlas board we can increase the number of LEDs accordingly.
Change:
/* Attempt to toggle the 4 LEDs */
const uint32_t bits = 4;
To:
/* Attempt to toggle the 8 LEDs */
const uint32_t bits = 8;
[image: ]
Don’t forget to save the edited file.
To undo full-screen mode for the editor view, double click on the “hwlib.c” tab.
Change the FPGA image
We will also need to change the FPGA configuration file.
To do this, select the project and then select File->Import->File System
Browse to the folder C:\ASDF\Atlas, check the box next to the file soc_system.sof.
[image: ]


To prevent soc_system.sof from getting deleted after a “Build” or a “Clean project” open Makefile and make the following change:
From:
clean:
	$(RM) $(ELF) $(SPL) $(OBJ) *.objdump *.map *.rbf $(HWLIBS_SRC) alt_interrupt_armcc.* soc_system* cpf_option.txt
To:
clean:
	$(RM) $(ELF) $(SPL) $(OBJ) *.objdump *.map *.rbf $(HWLIBS_SRC) alt_interrupt_armcc.* soc_system_* cpf_option.txt

Also in Makefile remove or comment out the following two lines:
soc_system.sof: $(SOCEDS_ROOT)/examples/hardware/cv_soc_devkit_ghrd/output_files/soc_system.sof
	$(CP) $< $@


[image: ]
Then save the Makefile (File->Save) and select the project and then right-click and select “Build Project”.  Switch to the Console view to see the build details and to see if the build is successful.
[image: ]
To download and debug this example, create a new debug configuration and name it something like:
Altera-SoCFPGA-HardwareLib-FPGA-CV-ARMCC-Debug-Atlas
Setup the correct Connection, and Files, and Debugger setting from previous debug connections.  The executable file is named “hwlib.axf”.
[image: ]
Make sure that the Preloader Debug Connection has already run since the last time the board was powered-down or reset.  If not then run the Preloader by selecting Run->Debug Configurations-> RunPreloader and then select Debug.  
Then reopen the new Debug Configuration (i.e. Altera-SoCFPGA-HardwareLib-FPGA-CV-ARMCC-Atlas) to launch this example.  Select Debug to start it.


[bookmark: _Toc431907853]Connecting to the UART
It is not necessary to connect to the serial (UART) console for this session, however the DS-5 AE comes with a terminal view that can be used to watch the UART console during the boot process or through serial or through serial or Ethernet (SSH) after Linux has been booted.  To use the Terminal View, from with DS-5, select Window->Show View->Other.  Then expand the Terminal option and select Terminal.
Once the Terminal view is open, select the Settings icon [image: ] and configure as follows (for UART):[image: ]
If the UART/USB cable is connected, then determine the port by using Device Manager.  [image: ]
If the FTDI USB/UART driver has been installed, the correct COM port will show up as USB Serial Port (COMx) where x is the number to be determined.  In this example it is COM7.  Click on Connect [image: ] to open the serial connection.  It should look similar to the following:
[image: ]
An alternative to the UART is an SSH connection to the target.  If the target board has booted the Linux application, then the SSH connection though Ethernet via the USB connection should also provide a console interface.
[bookmark: _Toc431907854]Potential Issues
[bookmark: _Toc431907855]Debug Cable Doesn’t Work
Be sure that the USB Blaster II driver is installed and that it functions. Generally, following the development kit installation instructions and going through a few of the recommended examples is good enough to solve this issue.
[bookmark: _Toc431907856]FPGA Isn’t Programmed Successfully
Refer to specifics on your development kit, but usually this is due to a mismatched MSEL (programming mode). Refer to the MSEL section in the “readme.txt” file that is included with the example for more information.
[bookmark: _Toc431907857]Temporary Directories not Writable
Though uncommon, it is possible for temporary directories that the Eclipse-based DS-5 debugger relies on being writable to be un-writable. If you run into strange “permission denied” issues when starting debug sessions, search through all temporary directories in your environment (tmp, TMP, temp, TEMP) and change/set them to a writable directory.
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